summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDanny Holman <dholman@gymli.org>2024-10-14 21:04:19 -0500
committerDanny Holman <dholman@gymli.org>2024-10-14 21:04:19 -0500
commit7ec4bf7c73869fbf641dd642d8e413afc2e0a829 (patch)
treecfca2b4f9c1abdf4de1b741cb7ae850b9c2f3310 /CMakeLists.txt
parentf9a9720d3d34cf213a5393cdfdac989bed913e1a (diff)
core: mod: create a mod interface
Create a skeleton mod interface so that the engine can load shared libraries or DLLs as in-game mods. The API should be compiler agnostic as much as possible. Signed-off-by: Danny Holman <dholman@gymli.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1c9ce1d..dda668d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -14,7 +14,9 @@ list(APPEND SOURCE_FILES
core/callbacks.c
core/init.c
core/logging.c
+ core/mod.c
core/network.c
+ core/thread.c
)
list(APPEND SOURCE_FILES