summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDanny Holman <dholman@gymli.org>2024-09-17 02:22:44 -0500
committerDanny Holman <dholman@gymli.org>2024-09-17 02:22:44 -0500
commit43e60465a0b5686f3db71c87a1d73717d93e9964 (patch)
tree0c6ccfce374291e6a13c78605d06bf3385a39c0d /CMakeLists.txt
parent70c912b7d545515823d0b06953a8afe0253ab09c (diff)
ui: add new subsystemv0.61
Add the UI subsystem. This subsystem will control the window display, events and input. Signed-off-by: Danny Holman <dholman@gymli.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 38db705..cc8828e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -15,6 +15,12 @@ list(APPEND SOURCE_FILES
core/network.c
)
+list(APPEND SOURCE_FILES
+ ui/window.c
+ ui/input.c
+ ui/renderer.c
+)
+
set(HEADER_DIR include)
add_compile_definitions(VERSION="${PROJECT_VERSION}")