summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDanny Holman <dholman@gymli.org>2024-09-17 02:20:35 -0500
committerDanny Holman <dholman@gymli.org>2024-09-17 02:20:35 -0500
commit70c912b7d545515823d0b06953a8afe0253ab09c (patch)
tree1a7338116ff057c67795e6da93190d4c9bee9e62 /CMakeLists.txt
parent4c4314bb0e183d71c7e9f6c71ddccf55a1eed5a5 (diff)
core: add several new files
Add several new files to the core subsystem. These files will be the basic building blocks upon which the rest of the engine will sit atop of. These files will be present in all builds, including headless and platform builds. Signed-off-by: Danny Holman <dholman@gymli.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt20
1 files changed, 16 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 551cf1f..38db705 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -4,13 +4,25 @@ set(CMAKE_C_STANDARD 23)
set(CMAKE_C_STANDARD_REQUIRED ON)
set(CMAKE_C_EXTENSIONS ON)
-project(rune-engine VERSION 0.60.0 DESCRIPTION "High performance game engine designed for Quake-style shooters")
+project(rune-engine VERSION 0.61.0 DESCRIPTION "High performance game engine designed for Quake-style shooters")
-list(APPEND SOURCE_FILES core/abort.c core/alloc.c core/callbacks.c core/init.c core/logging.c core/network.c)
+list(APPEND SOURCE_FILES
+ core/abort.c
+ core/alloc.c
+ core/callbacks.c
+ core/init.c
+ core/logging.c
+ core/network.c
+)
-add_compile_definitions(VERSION="${PROJECT_VERSION}")
+set(HEADER_DIR include)
+add_compile_definitions(VERSION="${PROJECT_VERSION}")
add_library(${PROJECT_NAME} SHARED ${SOURCE_FILES})
+
+target_include_directories(${PROJECT_NAME} PUBLIC ${HEADER_DIR})
set_target_properties(${PROJECT_NAME} PROPERTIES VERSION ${PROJECT_VERSION})
set_target_properties(${PROJECT_NAME} PROPERTIES SOVERSION ${PROJECT_VERSION_MAJOR})
-target_include_directories(${PROJECT_NAME} PRIVATE include)
+
+install(TARGETS ${PROJECT_NAME} DESTINATION lib)
+install(DIRECTORY ${HEADER_DIR}/rune DESTINATION include)