summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDanny Holman <dholman@gymli.org>2024-09-18 01:08:04 -0500
committerDanny Holman <dholman@gymli.org>2024-09-18 01:08:04 -0500
commit0b301a7ed041c85548b896418d926563e6eb0762 (patch)
treeecab05468e89e907a97ba2dfa154867bc373dbcc /CMakeLists.txt
parent43e60465a0b5686f3db71c87a1d73717d93e9964 (diff)
core: logging: print errors and warnings in color
Print warnings and errors in yellow and red respectively. This will make these messages stand out and make it easier for a developer to find them in the terminal window. Signed-off-by: Danny Holman <dholman@gymli.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index cc8828e..d64deb7 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -26,6 +26,7 @@ set(HEADER_DIR include)
add_compile_definitions(VERSION="${PROJECT_VERSION}")
add_library(${PROJECT_NAME} SHARED ${SOURCE_FILES})
+set_property(TARGET ${PROJECT_NAME} PROPERTY ENABLE_EXPORTS ON)
target_include_directories(${PROJECT_NAME} PUBLIC ${HEADER_DIR})
set_target_properties(${PROJECT_NAME} PROPERTIES VERSION ${PROJECT_VERSION})
set_target_properties(${PROJECT_NAME} PROPERTIES SOVERSION ${PROJECT_VERSION_MAJOR})