summaryrefslogtreecommitdiff
path: root/server/configure.ac
diff options
context:
space:
mode:
authorDanny Holman <dholman@gymli.org>2023-01-04 00:33:15 -0600
committerDanny Holman <dholman@gymli.org>2023-01-04 00:33:15 -0600
commit760fada7269b083ce00a1f18a4fb1cbb9ab13dc7 (patch)
tree8c1f806f761abbc7c55245b82cb5338c2af084b7 /server/configure.ac
parentbe4f102b8aa16bb90ed7d8d51a84650987dfdb40 (diff)
logging: add a close function
Add a close function to close the file handle pointing at the log file. Signed-off-by: Danny Holman <dholman@gymli.org>
Diffstat (limited to 'server/configure.ac')
-rw-r--r--server/configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/server/configure.ac b/server/configure.ac
index 7f2e0d5..4309259 100644
--- a/server/configure.ac
+++ b/server/configure.ac
@@ -9,7 +9,7 @@ AC_CONFIG_MACRO_DIR([../m4])
AM_INIT_AUTOMAKE([1.16 -Wall -Werror foreign subdir-objects])
AC_CONFIG_FILES([Makefile])
-AC_CHECK_HEADERS([stdio.h stdlib.h string.h pthread.h arpa/inet.h sys/socket.h])
+AC_CHECK_HEADERS([stdio.h stdlib.h string.h pthread.h arpa/inet.h sys/socket.h], [], AC_MSG_ERROR([missing required headers]))
AX_CHECK_COMPILE_FLAG([-Wall], [CFLAGS+=" -Wall"])
AX_CHECK_COMPILE_FLAG([-Wextra], [CFLAGS+= "-Wextra"])